Mail.ruПочтаМой МирОдноклассникиВКонтактеИгрыЗнакомстваНовостиПоискОблакоComboВсе проекты

Старые Android-смартфоны перестанут открывать сайты в 2021 году

В 2021 году могут возникнуть проблемы у владельцев смартфонов, которые не обновлялись с 2016 года — из-за устаревшего сертификата устройства перестанут открывать сайты в браузере. Но есть решение.

Let's Encrypt, которая в 2015 году вместе с компанией IdenTrust ввела перекрестную подпись для сертификации сайтов с шифрованием, сообщила, что в сентябре 2021 года у этого сертификата заканчивается срок действия. Это значит, что большинство старых устройств перестанут нормально открывать сайты.

pixabay.com

Этот корневой сертификат DST Root X3 перестанет работать с 1 сентября 2021 года, но компании не договорились о его продлении, поэтому Let's Encrypt готова перейти на собственный сертификат.

Проблемы возникнут с устройствами, которые не обновлялись с 2016 года. Это в первую очередь смартфоны с Android 7.1.1 и более старыми версиями — в этих системах работает устаревший сертификат, который перестанет поддерживаться в следующем году.

У этой проблемы есть несколько решений. Самое простое — взять более современный смартфон. Еще можно надеяться, что производитель выпустит обновление с новыми сертификатами для браузера к устаревшим смартфонам или разработчики сайтов смогут обойти ограничение устаревшего корневого сертификата, но это нужно делать на каждом отдельном домене.

Если нет возможности поменять смартфон, то можно пользоваться Firefox — это единственный браузер, который полагается на собственный список корневых сертификатов, а не берет их из системы устройства. В нем все сайты должны открываться.

Проблема серьезная, потому что корневыми сертификатами Let's Encrypt пользуется около трети доменов в глобальном интернете — больше 200 миллионов сайтов по всему миру. Сейчас Android 7 и более старые версии стоят на 33,8% смартфонов.

Полезная хитрость: сейчас за добавление любых товаров в корзину раздают монеты бесплатно (подробнее). Используйте выгодные купоны, чтобы максимально сэкономить во время главной распродажи года на AliExpress (посмотреть хиты продаж). Особые скидки, если завести новый аккаунт и сделать заказ (узнать цены).

Это тоже интересно:

Во время загрузки произошла ошибка.
Расскажите друзьям о проблемах со старым Android, для репоста нажмите на кнопку соцсети ниже
Обзоры новинок
Подробности о главных премьерах
Комментарии
19
Евгений
В ответ на комментарий от adminmike История переписки2
adminmike
Попробуйте оперу с впном или тот фаерфокс.
СсылкаПожаловаться
а прикол в том, что ни оперы, ни фф не установлено, а файлы апк аппарат не открывает, появляется уведомление, что установщик не функционирует. одна надежда сделать рут, но я в этом не понимаю
СсылкаПожаловаться
adminmike
В ответ на комментарий от анатолий косиков
анатолий косиков
Я не хочу менять телефон он меня устраивает а версия 7.0 asus zenfone3 max
СсылкаПожаловаться
Аналогично.
СсылкаПожаловаться
adminmike
В ответ на комментарий от АРТУР ВАРТАНЯН
АРТУР ВАРТАНЯН
Вообще насрать каждые два года меняю телефон
СсылкаПожаловаться
А я нет! :D
СсылкаПожаловаться
adminmike
В ответ на комментарий от Евгений
Евгений
уже сейчас не поддерживается Андроид версии 4.5. У меня 2 аппарата лежат в прекрасном техническом состояении, но функционально сейчас это что-то вроде аудио-видео плеера. Не работают акаунты гугл и магазины приложений, не запускаются браузеры.
СсылкаПожаловаться
Попробуйте оперу с впном или тот фаерфокс.
СсылкаПожаловаться
Александр
Теперь очередь яблочников смеяться над андройдом крайне активно :)))
СсылкаПожаловаться
Василич
Найдется умный дядька и запилит патч с новым сертификатом, а вы панику развели...
СсылкаПожаловаться
Oleg Shuklin
В ответ на комментарий от Евгений История переписки3
Евгений
ошибочка, сейчас посмотрел, Sony Ericsson Walkman wt19i с версией 4.4 и планшет самсуг Р6800, родоначальник S-серии, на нем 4.0.4.
Ничего не работает, кроме вшитых просмотрщика фото/видео и плеера. На планшете еще работают установленные давно игры.
Ни ни акаунт, ни магазин приложений, ни хром или вшитые браузеры, у самсунга свой, у сони дельфин - ничто не работает.
даже закинул установочный файл .apk - и то не распаковывает, т.к. установщик не работает.
и что особенно неприятно, ломаную винду любой версии в интернете найти гораздо легче, чем андроид))
СсылкаПожаловаться
Очень странно... Некоторые производители программ только сейчас (!) отказываются от поддержки второй (!) версии Андроида, а у вас четвёртая уже не работает на двух устройствах...
Не пробовали искать на 4ПДА ? Там есть большие форумы по обоим аппаратам - и Sony Ericsson Live with Walkman, и Samsung GT-P6800 Galaxy Tab 7.7. Может, что-то полезное найдётся?
СсылкаПожаловаться
Евгений
В ответ на комментарий от Oleg Shuklin История переписки2
Oleg Shuklin
1) Разве у Андроида была версия 4.5?
2) Странно, у меня до последнего времени был вторым телефоном "Самсунг" с версией 4.1.2, там и аккаунт Гугла работал, и магазин, и Хром. Правда, некоторые приложения не обновляются до последних версий (версия Хрома, например, от 2015 года какая-то), но работают.
СсылкаПожаловаться
ошибочка, сейчас посмотрел, Sony Ericsson Walkman wt19i с версией 4.4 и планшет самсуг Р6800, родоначальник S-серии, на нем 4.0.4.
Ничего не работает, кроме вшитых просмотрщика фото/видео и плеера. На планшете еще работают установленные давно игры.
Ни ни акаунт, ни магазин приложений, ни хром или вшитые браузеры, у самсунга свой, у сони дельфин - ничто не работает.
даже закинул установочный файл .apk - и то не распаковывает, т.к. установщик не работает.
и что особенно неприятно, ломаную винду любой версии в интернете найти гораздо легче, чем андроид))
СсылкаПожаловаться
Сергей
В ответ на комментарий от анатолий косиков
анатолий косиков
Я не хочу менять телефон он меня устраивает а версия 7.0 asus zenfone3 max
СсылкаПожаловаться
Аналогично. Версия 5.1
СсылкаПожаловаться
Сергей
Зачем вообще эти сертификаты. Очередной геморрой пользователям
СсылкаПожаловаться
Oleg Shuklin
В ответ на комментарий от Евгений
Евгений
уже сейчас не поддерживается Андроид версии 4.5. У меня 2 аппарата лежат в прекрасном техническом состояении, но функционально сейчас это что-то вроде аудио-видео плеера. Не работают акаунты гугл и магазины приложений, не запускаются браузеры.
СсылкаПожаловаться
1) Разве у Андроида была версия 4.5?
2) Странно, у меня до последнего времени был вторым телефоном "Самсунг" с версией 4.1.2, там и аккаунт Гугла работал, и магазин, и Хром. Правда, некоторые приложения не обновляются до последних версий (версия Хрома, например, от 2015 года какая-то), но работают.
СсылкаПожаловаться
Огонь в ночи
Интересно, а клоны огнелиса смогут так же открывать или нет?
СсылкаПожаловаться
Алексей С.
так дали же рецепт, огнелис должен все открывать
СсылкаПожаловаться
Константин Гущин
Очередной способ придумали, чтоб за новыми смартами пошли, а то кучу новинок с теми же функциями навыпускали, а потребность опять падать начинает.
СсылкаПожаловаться
Евгений
уже сейчас не поддерживается Андроид версии 4.5. У меня 2 аппарата лежат в прекрасном техническом состояении, но функционально сейчас это что-то вроде аудио-видео плеера. Не работают акаунты гугл и магазины приложений, не запускаются браузеры.
СсылкаПожаловаться
STAR_TREKKER
Буря в стакане. Всегда есть способ обхода ограничений.
СсылкаПожаловаться
Yura Efremov
google изначально отдавал бесплатно свою ось теперь пытается все монетизировать
СсылкаПожаловаться
анатолий косиков
Я не хочу менять телефон он меня устраивает а версия 7.0 asus zenfone3 max
СсылкаПожаловаться
АРТУР ВАРТАНЯН
Вообще насрать каждые два года меняю телефон
СсылкаПожаловаться
Чтобы оставить комментарий, вам нужно авторизоваться.
Вы не ввели текст комментария
Вы не ввели текст комментария
Обнаружили ошибку? Выделите ее и нажмите Ctrl+Enter.
Подпишитесь на нас